Symptom
You are being charged for Verify V2 API requests to phone numbers that are invalid.
Applies To
- Verify V2 API
- Outbound SMS via Verify V2
Resolution
The Verify service has been updated to reject invalid phone numbers synchronously at the Verify V2 API level. You will no longer be charged for these transactions. No action is required on your part, the update is applied automatically.
Cause
Previously, validation of numbers took place at a later stage in the transmission cycle. This allowed verify requests directed at invalid numbers to proceed and incur charges, despite being unsuccessful
What Has Changed
To enhance efficiency and ensure cost transparency, Verify now performs immediate validation of requests. When an invalid number is detected, the Verify API rejects the request directly and returns a synchronous error response (Error code 422 – ‘to’ phone number is invalid). Because these requests do not enter the transmission cycle, no transaction occurs and no charges are applied to requests rejected by the Verify V2 API
Additional Information
- This update only affects charges for invalid number requests that are synchronously rejected by Verify V2 API. Standard rates still apply for all successful verification attempts and retries
- The way you integrate and call the Verify API remains unchanged
Related to:
Articles in this section
- What is the Verify Anti-Fraud System?
- Verify API service to restricted countries
- Can I use Verify API with any number in the world?
- Rejection for Invalid Number in Verify V2
- Why does Verify Dashboard Analytics report less traffic than the invoice?
- Does Silent Authentication work for users with Apple’s Private Relay enabled?
- How to Change the Validity Period for Verify PIN Codes?
- Understanding the error code 409 when creating a Fragment for Custom Template in Verify API V2.
- What are the charges for using Verify API V2?
- Does Silent Authentication work with eSIM?