Why do you send the webhook to my old URL? Why do you send the webhook to my old URL?

Why do you send the webhook to my old URL?

Nexmo Support

Symptom

I have updated my webhook URL on API settings but you still send requests to the previous one.

Applies To

  • Webhooks
  • Dashboard

Resolution

There are two sets of webhook URLs you can configure on the Dashboard:

  • Account Level - Found under the Settings page in the Dashboard.
  • Number Level - Found under Your Numbers when editing your numbers.

Note that the webhook URL associated with your number will always take priority over the account level one. To solve this issue, you can either remove or update the number level webhook URL.

Cause

A number level webhook URL persists.