Credit Card Invoice Link Not Available
Symptom
When attempting to generate an invoice for a credit card payment, the invoice link is not available.
Applies To
- Invoices
- Billing and Payments
- Credit Card Payments
Resolution
Credit card payments are typically applied within 72 hours. If 72 hours have not passed since you made the payment, try to access the invoice link again in a few days.
Cause
Credit card invoices are available for credit card payments after the payment has been received by Vonage, usually within 72 hours of payment.
Additional Information
If your issue also affects other payment types, see Why can't I create an invoice?
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