Symptom
Verify SMS was not delivered to my number.
Applies To
- Verify API
- SMS
- TTS
Resolution
If your mobile number has been incorrectly classified as a landline number, and you are able to confirm the number is a mobile number and the network it is on, submit a Support request so that we can assist you with this issue.
Cause
When using Verify you will not receive an SMS if your number is listed as a landline. Unfortunately the USA and Canada can be a very challenging area for identifying whether a number is a mobile or landline number, due to sharing the same prefixes. Due to this, many providers can classify a number incorrectly. Some landlines do have the ability to accept SMS, but the majority do not. Due to this, we will not attempt to send an SMS to this number and will proceed only with the Text-to-Speech (TTS) call which will provide the PIN to you.
Even if an SMS is not sent, a TTS call will still occur to the number providing the PIN to the user.
Articles in this section
- What is the Verify Anti-Fraud System?
- Verify API service to restricted countries
- Can I use Verify API with any number in the world?
- Rejection for Invalid Number in Verify V2
- Why does Verify Dashboard Analytics report less traffic than the invoice?
- Does Silent Authentication work for users with Apple’s Private Relay enabled?
- How to Change the Validity Period for Verify PIN Codes?
- Understanding the error code 409 when creating a Fragment for Custom Template in Verify API V2.
- What are the charges for using Verify API V2?
- Does Silent Authentication work with eSIM?