Symptom
Even when the Allowed IP List feature is expected to be active, the JS SDK behaves as through the feature is not enabled.
Applies To
- OpenTok
- JS SDK
- Enterprise environment projects
- Allowed IP List
Resolution
Pass the ipWhitelist flag correctly as a boolean:
Correct
OT.initSession(apiKey, sessionId, { ipWhitelist: true }); Incorrect
OT.initSession(apiKey, sessionId, { ipWhitelist: 'true' });
Cause
This issue occurs when the ipWhitelist flag is passed as a string instead of a boolean.
Additional Information
When the Allowed IP List is not activated, connection setup may take longer, but the session will still connect successfully.
For full setup instructions and all required steps, please refer to the developer guide:
OpenTok: https://tokbox.com/developer/guides/ip-addresses/
Unified: https://developer.vonage.com/en/video/guides/ip-addresses
Related to:
Articles in this section
- How do I create and manage my Video API applications in the Unified Environment
- JS SDK: Allowed IP List not applied when ipWhitelist is passed as a string
- Activating Two Factor Authentication on Your Opentok Video API Account
- How to Add Users, Remove Users and Manage User Permissions?
- Can I create multiple sub-projects within a single Video API project in my Opentok Video API account?
- How do I change my Vonage Video API Account name?
- How do I change the preferred video codec for my video project or application?
- How do I check the countries where my application is being used and quality per country?
- How do I check the Video Express usage?
- How do I generate a session ID using the Vonage Video API (Opentok Environment) project dashboard?