Why am I receiving an error "We could not set up your number for the selected API key. Please try a different API key" Why am I receiving an error "We could not set up your number for the selected API key. Please try a different API key"

Why am I receiving an error "We could not set up your number for the selected API key. Please try a different API key"

Asha Chintaluru

Symptom

Received an error "We could not set up your number for the selected API key. Please try a different API key" when trying to set up my number with the selected API key via embedded signup.

Applies To

  • WhatsApp Embedded sign-up
  • Messages API
  • WhatsApp Onboarding

Cause

The error message you received, "We could not set up your number for the selected API key. Please try a different API key," indicates that the issue is related to the association of the WhatsApp Business Account (WABA) with the API account. The problem arises from an attempt to activate the new number by associating it with a different API account.

It's important to note that each WABA can only be associated with one main API key. The numbers within the WABA can belong to any of its sub-API keys. However, it is not possible to set up different numbers associated with completely different main API keys.

 

Resolution

To resolve this issue, follow one of the two options:

  1. Activate the additional number with an API key that belongs to the same account as the existing one.
  2. Request to move the existing phone number to the new account via the API key change process. You can initiate this request by submitting an  API Key Change Request.

Additional Information

How to change the API Key for a WhatsApp Business Number