No Audio In Programmable SIP IVR No Audio In Programmable SIP IVR

No Audio In Programmable SIP IVR

Vonage API Support

Symptom

An issue was happening for a user of the Voice API where no audio could be heard in a custom IVR application.

Applies To

  • Vonage Voice API 

Resolution

  1. Make sure the Application ID associated with the SIP Trunk is the same as the one used to generate the JWT (JSON Web Token) for the application.

  2. Also, make sure the correct region_url is being used in the application.

Cause

The application ID associated with the sip trunk was different than the one used to generate the JWT.

Additional Information

This issue was encountered when building the Contact Center Augmentation tutorial.