Symptom
WhatsApp messages are getting rejected with Error 1340, "Outside of the allowed window—This message is sent outside of the allowed response window."
Applies To
- Messages API
Resolution
Ensure that you are using a templated message.
Cause
This error occurs if a free-form or non-templated WhatsApp message is sent outside the Customer Care Window (24 hours after an end-user sends a message to the customer). WhatsApp requires that any message that is sent to a user for the first time, or that is outside the Customer Care Window be a templated message, therefore, freeform or non-templated messages will be rejected with error code 1340 (WhatsApp error codes:470-for On-Premise number,i.e Vonage hosted number and 131047 for WhatsApp Cloud number,i.e WhatsApp hosted numbers).
Additional Information
For more information, see Facebook's WhatsApp Messages Guidelines.
Articles in this section
- WhatsApp Per User Marketing Template Messaging Limits
- Why did I receive rejected status delivery receipts although my WhatsApp messages were delivered to enduser?
- WhatsApp Quality Rating and Messaging Limits
- WhatsApp Platform: Phone Number Limits
- WhatsApp Business Platform Policy Enforcement: Review and Appeal Process for WhatsApp Disabled Account
- WhatsApp Local Data Storage
- Why am I receiving an error "We could not set up your number for the selected API key. Please try a different API key"
- WhatsApp One WABA Policy Enforcement Jan 2024
- WhatsApp Authentication Template Compliance May 2024
- Error code 1022 Template name does not exist in the translation