Symptom
My WhatsApp messages are not delivered in order.
Applies To
Resolution
To resolve this issue we advise our users to try one of the following options:
- Merge both messages into one message when you expect to send two messages with a short time difference to the same destination.
- Make sure a minimum delay of 500 milliseconds is elapsed between one message and the next message to the same destination.
- Stop sending messages to one destination until you get the Submitted (or Error) status event from the last message sent to that destination.
Cause
WhatsApp has a known issue where if messages are sent too close together they may not deliver in the correct order.
Articles in this section
- Why is my WhatsApp Messaging Limit still at 250 and Display Name not visible after Business Verification?
- WhatsApp Display Name – Approval, Review & Appeal Process
- Understanding WhatsApp Usernames and Business-Scoped User IDs (BSUIDs) – Required Actions and Changes
- Understanding the "Business Verification Needed.." Message in WhatsApp Manager for Restricted WABA Accounts
- WhatsApp Business Account Locked - Error 1330
- WhatsApp Vonage Managed Manual Onboarding Form No Longer Available for partners
- What to do if you see "The new display name has been approved. Register your number to start using it"?
- What is the 24-Hour Customer Care Window
- How to generate JWT token using Vonage Online JWT generator tool?
- Getting started with Vonage's WhatsApp Business Account : Hosted Embedded Sign-Up for Partners' End Customers