Symptom
Users receive an error type: 'BAD_REQUEST', error_title: 'Bad Request'
upon trying to terminate calls shortly after initiating them.
Applies To
- Voice API
Resolution
- Please wait at least 2 seconds after initiating an API call before attempting to end it.
- You can implement a retry mechanism in your application, such as adding retries after short timeouts if the response error status is 400.
Cause
The system necessitates a delay of about 1 to 2 seconds to fully establish the call before it can be updated or terminated.
Articles in this section
- How To Check Call Quality With Voice Inspector
- What is a Conversation ID?
- How to configure the custom webhook timeout for Voice API functionality and what are the allowed timeout ranges ?
- How do I change TTL for the Conversations and Call Legs?
- Why are call progress events not being received on the Event URL defined in the conversation action NCCO?
- Why is there an extended silence at the beginning of a call and how can it be reduced?
- Intermittent WebSocket Disconnections
- What Is An NCCO
- How Does Jitter Impact Voice Calls
- Voice API "Bad Request" Error When Ending Calls Immediately After Creation