Symptom
Users receive an error type: 'BAD_REQUEST', error_title: 'Bad Request' upon trying to terminate calls shortly after initiating them.
Applies To
- Voice API
Resolution
- Please wait until you have received the ringing webhook before attempting to end it.
- You can implement a retry mechanism in your application, such as adding retries after short timeouts if the response error status is 400.
Cause
A call cannot be cancelled until it has reached the ringing state.
Articles in this section
- Why is the UUID not present when DTMF times out
- Multiple Record Actions in Same Conversation
- Do we retry if the voice event webhook fails?
- How do I verify that the Voice API Webhook request and it's payload has not been tampered during transit?
- How To Check Call Quality With Voice Inspector
- What is a Conversation ID?
- How to configure the custom webhook timeout for Voice API functionality and what are the allowed timeout ranges ?
- How do I change TTL for the Conversations and Call Legs?
- Why are call progress events not being received on the Event URL defined in the conversation action NCCO?
- Why is there an extended silence at the beginning of a call and how can it be reduced?