Why am I not receiving WhatsApp inbound messages? Why am I not receiving WhatsApp inbound messages?

Why am I not receiving WhatsApp inbound messages?

Support Team

Symptom

I am not receiving WhatsApp inbound messages to the URL configured in my Application.

Applies To

  • Messages API
  • Webhook URL
  • Application
  • Inbound Messages
  • WhatsApp

Resolution

To receive WhatsApp inbound messages on your Application webhook URL, you need to link your WhatsApp ID to your Application. Refer to the article Post Go-Live Guide: Start Using WhatsApp on how to link your WhatsApp ID to your Application.

Cause

If the WhatsApp ID is not linked to the Application, then the inbound messages would be sent to the URL configured in your Account API key, and if no webhook URL is configured at the account level, then you won't be receiving any inbound messages.

Another potential cause is inactivity. If a WhatsApp Business number remains inactive for 30 days, Meta will automatically lock the number. In such cases, the number may appear as "connected" in WhatsApp Manager, even though it's locked on Meta's end. To verify whether the WhatsApp Business number is locked, please contact our support team for further assistance and validation.

Additional Information

For more information, see the following articles: