Symptom
I am not receiving WhatsApp inbound messages to the URL configured in my Application.
Applies To
- Messages API
- Dispatch API
- Webhook URL
- Application
- Inbound Messages
Resolution
To receive WhatsApp inbound messages on your Application webhook URL you need to link your WhatsApp ID to your Application. Refer to the article Post Go-Live Guide: Start Using WhatsApp on how to link WhatsApp ID to your Application.
Cause
If the WhatsApp ID is not linked to the Application then the inbound messages would be sent to the URL configured in your Account API key and if no webhook URL is configured at the account level then you won't be receiving any inbound messages.
Additional Information
For more information, see the following articles:
Articles in this section
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- Why am I receiving an error "We could not set up your number for the selected API key. Please try a different API key"
- WhatsApp One WABA Policy Enforcement Jan 2024
- WhatsApp Authentication Template Compliance May 2024
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