Symptom
When checking the RCS capability on the RCS-capable number/device, you receive this error:
{
"type": "https://developer.vonage.com/api-errors#not-found",
"title": "End User Not RCS Reachable",
"detail": "User device or number not supported by RCS.",
"instance": "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
}
Applies To
- RCS
Cause
This happens because the number is not registered or added as a tester number on your relevant RCS Agent.
Resolution
You have to add or register the number as a tester.
You can add it via the RCS Agent builder on your Vonage Dashboard. This is available on Step 4.
If your RCS Agent was not created via the Dashborad's RCS Agent builder, you should contact Vonage API Support team to add the test number, by informing:
- Your Apikey
- Your RCS Agent Name or Sender-ID
Additional Information
Articles in this section
- Why I Receive Error Code 1251 (Unroutable) for France RCS?
- Why RCS Capability Checking Failed to RCS-capable Number/Device
- How Can I Deliver a Great Webview Experience in RCS Without Knowing the User's Device?
- How to Capture and Share HAR & Log Files for RCS Portal Support
- What Happens When a Non-RCS User Scans a QR Code for an RCS Welcome Message?
- Managing RCS Agents: What to Do If You Need Changes or Removal