Message Delivery Failed Error 10 Invalid Message Message Delivery Failed Error 10 Invalid Message

Message Delivery Failed Error 10 Invalid Message

Nexmo Support

Symptom

When attempting to send an outbound SMS, you receive an error that reads Error 10 - Invalid Message.

Applies To

  • Outbound SMS
  • Message Delivery
  • SMPP

Resolution

  • Ensure that you have the proper encoding flag for your outbound SMS.
  • If you are an SMPP user, ensure that you have the correct UDH.

Cause

This issue can occur when there is an error in the one of the parameters of the message (e.g., wrong encoding flag, or for SMPP users incorrect UDHs). It may also occur when the destination user has disabled the ability to receive messages (e.g., blacklist or Do Not Disturb setup).