Summary
JWT Tokens in the Unified Environment are larger than those in the TokBox environment.
Applies To
- Migrating from TokBox to the Unified Environment
- Authentication with JWT Tokens
Resolution
If JWT tokens are stored in a database, reviewing and updating the field size (to 900 chars) in the database schema to accommodate the increased token length is essential.
Failure to do so could result in errors or data truncation.
Please ensure that any database changes required to support the new token length are implemented accordingly before migrating from TokBox to the Unified Environment.
Cause
JWT tokens in the Unified environment are significantly longer, approximately 900 characters, compared to the 500-character tokens in the TokBox environment.
Additional Information
If you would like more information, please refer to our developer docs on JWT tokens in the unified portal.
Related to:
Articles in this section
- Migrating Video REST API from OpenTok to Unified
- Video Client SDK Changes from OpenTok to Unified
- How to Migrate from OpenTok Server SDK to Unified Server SDK
- Credential Differences Between OpenTok and Unified Environments
- In which Regional Media Zones can I use Experience Composer?
- How do I monitor Video API call quality in real-time?
- JWT Tokens in the TokBox and Unified Environments
- Android SDK 2.28.2 error when using the application context
- What happens if your session lasts more than 8 hours?
- Updates to using the Vonage Media Library in Native SDKs from version 2.27.x onwards