Subaccount API creation - Error 403 Subaccount API creation - Error 403

Subaccount API creation - Error 403

Tejashree Shivappa

Symptom

Received response 403 "Maximum number of sub-accounts reached" when creating a subaccount

Applies To

  • Subaccount API
  • Response 403
  • This account has reached maximum number of allowed sub-accounts

Resolution

Normal/Unmanaged Account :

  • The API is only offered to Partners (with restricted availability), and the creation of subaccounts is meant for its end users.
  • Currently do not get access to the Subaccounts API. 
  • A secondary API key is available to any API account, allowing the creation of an additional key and secret. This can then be assigned to a user for a specific use case within the same entity. If you do need help, please email support.

Partner Account :

  • Vonage Partners get access automatically.
  • If customers encounter this error, it is due to a restriction on the number of subaccounts that can be created for the partner account.
  • Customers should reach out to their Account manager or email support for help.
  •  

Cause

The request to create a new subaccount fails due to a provisioning error, either because the Subaccount API is not enabled or the Partner account has reached the maximum limit of allowed subaccounts.

Additional Information

Vonage Subaccounts API

Vonage Subaccounts API - Create SubAccount

What's the difference between a Subaccount API and a Secondary Account API?

API Errors - Subaccount API