Why am I getting Invalid Number Transfer Error Code Why am I getting Invalid Number Transfer Error Code

Why am I getting Invalid Number Transfer Error Code

Vonage API Support

 

 

Symptom

User attempting to move numbers in between accounts (from Master account to Subaccounts, or vice versa) while encountering the following error message:

{"type":"https://developer.nexmo.com/api-errors/subaccounts#invalid-number-transfer","title":"Invalid Number Transfer","detail":"Could not transfer number XXX from account XXX to XXX - ShortCodes that are dedicated, private, shared, non aged, or not owned by from account cannot be transferred from an account to another account","instance":"XXXXXXXXXXXXXXXXXXXXXX"}

Applies To

  • Subaccount API
  • API Error Codes

 

Resolution

Manually move the desired numbers by unsubscribing from one account and repurchasing it under another account or for batch request, open a support ticket

Cause

The current design of this feature is to allow non-dedicated numbers to be moved around freely and restricted for dedicated numbers.

Additional Information


https://developer.vonage.com/en/api-errors