Symptom
When publishing a stream, you get a similar error as below.
OT_HARDWARE_UNAVAILABLE: The selected voice or video devices are unavailable.
Verify that the chosen devices are not in use by another application.
Applies To
- Video API
Resolution
- Validate that the audio or video devices are not used by another application.
- Restart the audio or video device.
- Close all the background running apps that could have acquired the camera.
- Run Pre-Call Test to confirm that the device hardware meets the system requirements.
Cause
The OT_HARDWARE_UNAVAILABLE error indicates that the microphone or camera is not available. The audio or video device may have already been in use by another application or unavailable for other reasons.
Additional Information
Troubleshooting Issues with Video API
Articles in this section
- Checklist for when cycleVideo is not working in JavaScript
- Why Is My Video Camera Displaying a 4:3 Aspect Ratio Instead of 16:9 When Publishing in HD OR FHD resolution (1280x720)?
- How to use Completion handler for Exception Handling
- Firefox Pre-call test not supported
- Error Creating Session Using Vonage Video API .NET SDK
- Unable to Create Session Even Though API Key and Secret Are Valid
- HTTP 415 Error When Archiving Video Session
- Troubleshooting Invalid JWT When Creating a Video Session using REST API
- Camara Still in Use after Session Disconnect on Android
- Token Shows as Invalid