Symptom
When logging in or connecting calls to an app user, you see an error message that reads, "user:error:not-found, [username] doesn’t exist."
Applies To
- Conversation API
Resolution
When you see "user:error:not-found", "[username] doesn't exist", it is likely your Call/App user resides in a different data center. You can initialise the SDK to have your API request routed directly to another data center. Learn how to configure data centers in our developer documentation.
Cause
For inbound In-App Voice calls, users that have multi-geo requirements must initialise the SDK for the app user to connect to the Vonage data center hosting the call. Additionally, the user must also be created in the data center hosting inbound calls.
Conversations, Users, and Calls are currently tied to a geographic data center, depending on the location they originate from.
API requests are steered to Vonage data centers with the lowest round trip delay. For example, an API request to create an app User originating from an instance located in the US would be routed to a data center in the US.
Additional Information
The resolution is under development to enable full cross-data-center clustering to enable calls to move between data centers.
Articles in this section
- Session failed due to a timeout expiration
- Unable to initialize Client SDK on Android App API Level 31
- User:Error:Not-Found Username Doesn’t Exist When Logging in or Connecting Calls to an App User
- Why do I receive an answered event when I start an outbound call?
- Outbound In-App Voice Calls Fail to Complete
- Calls to an App User Don’t Time Out