Symptom
When trying to create a new session, you see an error "Session failed due to a timeout expiration"
Applies To
- Voice API
- Client SDK
Resolution
Below are some known solutions to address the issue. If none of these resolve the problem, please enable verbose logging, reproduce the issue, and send the logs to support. Additionally, please indicate the Client SDK version you are using.
For instructions on setting the logging level, you can refer to this link: configure-logging-level
- Ensure there are no network connectivity issues between your device and Vonage servers.
- Ensure the generated JWT token is not expired. You can validate using jwt.io
- Ensure that the mandatory Claim "sub" is defined with the username and not the user ID when generating the JWT user token. You can also use jwt.io to verify that the "sub" claim is correctly populated.
- Ensure that the users are created in the same data center region as your client SDK application. If no specific region is defined, the default is the US. For details on region configuration, you can refer: configure-data-center
Cause
This issue is typically caused by network connectivity problems, JWT Token issues, or Data center/region mismatches.
Additional Information
For more information on the regions, please refer to our developer documentation: https://developer.vonage.com/en/voice/voice-api/concepts/regions
To get the information about the users created and their regional URLs, please use: https://developer.vonage.com/en/api/application.v2#getUsers
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