Calls to an App User Don’t Time Out Calls to an App User Don’t Time Out

Calls to an App User Don’t Time Out

Aida Pourshirazi

Symptom

Calls to an app user do not timeout when specifying a timeout parameter in the NCCO.

Applies To

  • Timeout Parameter
  • Voice API

Resolution

It is recommended that you transfer the leg that is attempting to connect to the app user by using the PUT transfer Voice API request.

Cause

The timeout parameter is not supported if you have a connect action to an app endpoint. Instead, the default timeout of 60s applies to all calls to app endpoints.