How to Fix Device Registration Failure Due to Max Devices Limit How to Fix Device Registration Failure Due to Max Devices Limit

How to Fix Device Registration Failure Due to Max Devices Limit

Vonage API Support

Symptom

Users may encounter the error: [device:error:max-device-limit] The Request Failed Due to Registered Devices Exceeding Max Devices Limit per User, when trying to register a new device for a user.

Applies To

  • Voice API

  • Client SDK

Resolution

Follow these steps to resolve the issue:

1. Retrieve the list of registered devices for the user
Make a GET request to the following endpoint to check which devices are currently registered to the user:
GET https://api.nexmo.com/v1/users/<userId_or_username>/devices

Replace <userId_or_username> with the actual user ID or username.

2. Identify the device to delete
Review the list of devices returned in the response. Identify the devices that are no longer needed or in use.
Note the deviceId of the device you want to remove.

3. Delete the unused device
Make a DELETE request to remove the identified device:
DELETE https://api.nexmo.com/v1/devices/<deviceId>

Replace <deviceId> with the actual deviceId of the device to be deleted.

4. Verify the device removal
After the device is deleted, confirm that the device has been removed by making another GET request to retrieve the updated list of devices:
GET https://api.nexmo.com/v1/users/<userId_or_username>/devices

Cause

This issue occurs because the user has exceeded the maximum number of devices allowed to be registered.

Additional Information

For more information, please refer to our developer documentation:

List Users

Delete User