Unable to activate enterprise "Allowed IP list" feature for Vonage Unable to activate enterprise "Allowed IP list" feature for Vonage

Unable to activate enterprise "Allowed IP list" feature for Vonage

Kenny Domingo

Symptom

In a case where you are unable to activate "Allowed IP list" feature for Vonage, where config.opentok.com is being fetched instead of the config-enterprise.opentok.com i.e. from the allowed IP list. 

Applies To

  • JS SDK

Resolution

With JS SDK if you specify a ipWhitelist flag in initPublisher option, then it will directly fetch the resources from the allowed IP list.
 
Code snippet:
var session = OT.initSession(apiKey, sessionId, {ipWhitelist :true});
 
You can follow the below steps so the correct config file is downloaded from config-enterprise.opentok.com which is a part of the IP whitelist block.
 

OT.initSession(apiKey, sessionId, {ipWhitelist :true});
 
Using the above steps, you would see the enterprise version of config.json file will be requested and which is a part of the IP whitelist block.

Cause

Incorrect configuration i.e passing the ipWhitelist value in string quotations. While It needs to be boolean true.

  • With the IPwhitelist flag set,

OT.initSession(apiKey, sessionId, {ipWhitelist :'true'});

Additional Information

As a result, this will lead to slower connection times, but ultimately a successful connection.